MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Access & Datenbanken > Microsoft Access
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 19.09.2007, 15:56   #1
Sascha Trowitzsch
MOF Guru
MOF Guru
Strahlen Info - Access 2003 Service Pack 3

Hallo Leute,

Seit gestern gibt es ein neues Service Pack für Office 2003.
Nach dem SP2 folgt nun das SP3. Hier runterladen:
http://www.microsoft.com/downloads/d...displaylang=de
(Oder das Automatische Windowsupdate aktivieren. Das SP3 sollte dann auch mitkommen.)

Für alle A2003-User würde ich das auf jeden Fall empfehlen, denn A2003 hat schon noch die eine oder andere Macke.
Ich hab's allerdings gerade erst installiert und noch nicht durchgecheckt, was anders ist oder welche Bugs fehlen.

Gruß, Sascha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 19.09.2007, 18:45   #2
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Bitte das hier lesen, wer kann:
http://support.microsoft.com/?kbid=923618
Und natürlich die dort gelinkten Knowledgebase-Artikel, soweit sie für Access, aber auch für aus Access heraus automatisierte andere Office-Programme relevant sind.
Speziell zu Access:
http://support.microsoft.com/kb/938809/
http://support.microsoft.com/kb/938814/
Das ist wichtig, weil sich das Verhalten von A2003 nun damit ändert, wenn es nicht unter Administratorrechten ausgeführt wird.
Vor allem die Geschichte, dass Addins nicht mehr für alle User installiert werden, sondern nur noch für jeden User einzeln. ...Könnte noch für Verwirrung sorgen.

Und nun mein Lieblings-Fix:
Endlich gibt's nicht mehr dieses verfluchte Flackern von Steuerelementen auf Formularen, wenn man sich mit dem Mauszeiger über ungebundene Labels bewegt!
(Siehe dazu auch http://www.ms-office-forum.net/forum...light=flackern bzw. http://allenbrowne.com/ser-46.html )

Ciao, Sascha

PS: Dafür gibt es auch einen neuen durch das SP3 verursachten Bug. Konnte das nachstellen, was unter http://groups.google.it/group/micros...b0742114?hl=it steht

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de

Geändert von Sascha Trowitzsch (19.09.2007 um 19:25 Uhr).
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 20.09.2007, 10:52   #3
KurtKoerner
Neuer Benutzer
Neuer Benutzer
Standard

Hallo,

ich wollte dieses Update installieren, doch nach dem Aufruf des Programms und einer Weile des herumnudelns erscheinte die Meldung: "Das Update konnte nicht angewendet werden."

Eine sehr aufschlussreiche Fehlermeldung!! Ich habe Windows XP prof SP2 + alle aktuellen Hotfixes und Office 2003 prof, ebenfalls SP2.

Ich freue mich wenn mir jemand helfen kann.

Gruß
Kurt

Geändert von KurtKoerner (20.09.2007 um 11:02 Uhr).
KurtKoerner ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 20.09.2007, 11:05   #4
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Toll!
Das "Herumnudeln" scheint eine Besonderheit dieses Service Packs zu sein. Ich dachte auch erst, das es irgendwie abgestürzt ist, weil nach dem anfänglichen Entpack-Fenster, das nach ein paar Sekunden verschwindet, sich Ewigkeiten nichts tat. Der eigentliche Installer kam erst - sehr ungewöhnlich - nach ca. 30 Sekunden. Dann lief es problemlos durch. Ich habe A2000, O2003 und O2007 parallel auf dem Rechner - aber kein OXP.

Ich kann dir da nicht weiterhelfen. Wir müssen warten, ob sich ähnliches Verhalten wie bei dir auch noch bei anderen Usern einstellt und dann hoffen, dass MS ein Update des SP3 bereitstellt - ogott!
Mannmann, ich weiß auch nicht, was die in letzter Zeit anstellen! Das wird immer chaotischer...

Ciao, Sascha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 20.09.2007, 15:03   #5
KurtKoerner
Neuer Benutzer
Neuer Benutzer
Standard

Hallo Sascha,

Danke! Dann muss ich halt abwarten und beten, vielleicht hilfts.

Gruß
Kurt
KurtKoerner ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 20.09.2007, 16:40   #6
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Na, so eilig ist es auch nicht. Es sei denn, man möchte sich als Betatester verdingen. Inzwischen sind noch zwei andere Bugs gemeldet worden und bei mir funktioniert in einer 2003er-DB der grafische Formularaufbau nicht mehr so, wie davor. (Beim dynamischen Verkleinern eines Unterformulars zur Laufzeit bleibt jetzt ein Rand des UFos im Hauptformular stehen.) Mir scheint, dass die wegen dem Flacker-Bug die Paint-Routine von Formularen verändert haben und deswegen nun andere Seiteneffekte zum Tragen kommen.

Insofern relativiere ich meine Empfehlung oben, das SP3 zu installieren.
Im Gegenteil: Im Moment ist Abwarten angesagt und man sollte das automatische Windows-Update eher neu einstellen, damit das SP3 nicht so ganz im Hintergrund ohne Nachfrage installiert wird.

Ciao, Sascha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 21.09.2007, 20:24   #7
Köbi
MOF Profi
MOF Profi
Standard

Hallo

Ich habe SP3 installiert und festgestellt:

1. DB komprimieren verursacht nun noch häufiger als vorher einen Absturz. Anschliessend lässt sich die DB auch nicht mehr öffnen. Mit decompile bringe ich sie dann wieder zu laufen. Ist mir bei 4 verschiedenen DB's passiert.

2. Ich habe ein Modul importiert. Damit wird gleichzeitig bei allen bereits vorhandenen Modulen das Änderungsdatum auf Now() gesetzt. Das ist mir bisher nicht aufgefallen, ist das normal?

Kann man die Installation von SP3 rückgängig machen?

__________________

Gruss
Köbi
Köbi ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 22.09.2007, 12:42   #8
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Zitat:

Kann man die Installation von SP3 rückgängig machen?

Laut MS: Nein!
Das ist ja das Fiese.

In den letzten zwei Tagen sind in Newsgroups noch mehr Fehler im Zusammenhang mit Kombinations- und Listenfeldern bekannt geworden. Für einige dieser SP3-Bugs sind inzwischen Workarounds gefunden worden. MVP Allen Browne (http://allenbrowne.com/tips.html) kümmert sich zurzeit besonders um die Probleme. Ich denke, dass er bald eine separate Seite zu mit dem SP3 in Zusammenhang stehenden Fragen aufmachen wird, wo mögliche Lösungen aufgezeigt werden.
MS wird sicherlich nicht so super schnell einen Hotfix rausbringen.

Ziemlich unerfreulich, das Ganze!

Gruß, Sascha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 22.09.2007, 15:53   #9
Köbi
MOF Profi
MOF Profi
Standard

Danke, Sascha

Rückgängig machen ist also nicht, schade. Trotzdem noch eine Rückfrage.

Ist damit auch eine Systemwiederherstellung gemeint?
Da gleichentags ein Windows Update stattfand, wäre bei mir ein passender Wiederherstellungspunkt vorhanden.

__________________

Gruss
Köbi
Köbi ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.10.2007, 09:09   #10
Peter Medele
MOF User
MOF User
Standard Formatänderung

Hallo Sasha,
bei mir trat der „Formatfehler“ (>) wie von Allen Browne beschreiben in einem Kombinationsfeld auf. Komischerweise war die Formateinstellung nur im Frontend zu sehen und nicht im Backend????
Obwohl im Frontend normalerweise keine Änderungen möglich sind, konnte ich aber das Format (>) entfernen.

Gruß, Peter
Peter Medele ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 25.10.2007, 19:06   #11
micmen
MOF User
MOF User
Standard Workaround für Kombinationsfeld-Bug

Zitat: von Sascha Trowitzsch Beitrag anzeigen

In den letzten zwei Tagen sind in Newsgroups noch mehr Fehler im Zusammenhang mit Kombinations- und Listenfeldern bekannt geworden. (...) MVP Allen Browne (http://allenbrowne.com/tips.html) kümmert sich zurzeit besonders um die Probleme.

Hi,
ich habe auf dessen Seite leider lediglich eine Erwähnung des Kombinationsfeld-Bugs gefunden, aber keine Lösung?

Bei mir funktioniert es, wenn ich in der Datensatzherkunft von betroffenen Kombinationsfeldern bei den problematischen Feldern (Spalten) einen Leerstring, also ein "" & , vor den Feldnamen setze. Also angenommen, ein Feld PLZ macht Probleme, schreibe ich statt
Code:

... [Strasse], [PLZ], [Ort] ...
 
... [Strasse], "" & [PLZ], [Ort] ...
Der Leerstring verändert die Ausgabe nicht, kompensiert aus irgendwelchen Gründen aber den SP3-Bug...
micmen ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 26.10.2007, 10:32   #12
micmen
MOF User
MOF User
Standard

Hi mochmal,
da hier so viele negative Aspekte des SP3-Updates beschrieben sind, will ich mal meine Erfahrungen beisteuern:
Ich hatte seit vielen Monaten das Problem, daß sich Datenbank-Dateien kaum noch reparieren & komprimieren ließen. Beim ersten Mal kam eine Fehlerberichts-Auforderung, beim zweiten Mal lief es durch. Danach konnte ich aber nur noch das Datenbankfenster ungestraft schließen, beim Schließen des Access-Programmfensters kam wieder eine Fehlerberichts-Aufforderung.
Vor etwa 3 Wochen enthielt die Bestätigung der Fehlerberichtserstattung den Hinweis, daß ein Update verfügbar sei, das Usern mit ähnlichen Problemen weitergeholfen hätte.
Ich bin dem Link gefolgt und landete auf einer Seite mit bestimmt 15 Update-Empfehlungen, wählte alle an und ließ rattern. Das SP3-Update, das mit enthalten war, brauchte eine endlose Ewigkeit und meldete, nachdem es wirklich zu 100% durchgelaufen war, daß es fehlgeschlagen wäre, und ich es evtl. mal alleine ohne andere Updates laufen lassen sollte. Das habe ich etwa eine Woche später getan und seither kann ich wieder reparieren & komprimieren und auch Access problemlos beenden - schien also ein 100%iger Erfolg gewesen zu sein.

Und dann tauchte das absolut nicht erklärbare Problem mit leeren Spalten in der Auswahl von Kombinationsfeldern auf und ich landete bei diesem Thread hier...


P.S.: Ungeachtet meiner o.g. Popellösung würde ich mich noch dafür interessieren, ob es einen "etwas seriöseren" Workaround gibt? Bei Allen Browne habe ich, wie gesagt, zwar die Problembeschreibung, aber keine Lösung gefunden.
micmen ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 22.09.2007, 16:15   #13
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Das kann ich nicht sagen.
Es werden ja Systemdateien vom SP3 ausgetauscht, weshalb man nach Installation einen Neustart braucht - war zumindest bei mir so.
Welche Dateien das sind und ob die in deinem Wiederherstellungs-Paket drin sind, keine Ahnung ... Probier's halt mal aus.

Gruß, SAscha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 22.09.2007, 19:22   #14
Köbi
MOF Profi
MOF Profi
Standard

Hallo

Für jene, die es interessiert. Mit einer Systemwiederherstellung auf einen Wiederherstellungspunkt vor Installation von SP3 bringt man es wieder weg.

Ich habe jetzt wieder SP2 und auch das nette Flackern, wenn man den Mauszeiger über ungebundene Labels bewegt, ist wieder da. Ich hab's schon fast vermisst.

Und Achtung:

Zitat:

Im Moment ist Abwarten angesagt und man sollte das automatische Windows-Update eher neu einstellen, damit das SP3 nicht so ganz im Hintergrund ohne Nachfrage installiert wird.

Diesen Hinweis kann ich nur bestätigen. Sofort nach der Wiederherstellung ist bei mir der automatische Updater losgerannt und hat SP3 zum Update bereitgestellt. Zum Glück habe ich es so eingerichtet, dass nicht sofort automatisch die Installation beginnt.

__________________

Gruss
Köbi

Geändert von Köbi (22.09.2007 um 19:28 Uhr).
Köbi ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 22.09.2007, 20:54   #15
Sascha Trowitzsch
Threadstarter Threadstarter
MOF Guru
MOF Guru
Standard

Ich würde gerne noch auf eine weitere SP3-Macke hinweisen, die zumindest bei mir und einem aus dem Usenet auftritt:

- Ich gehe auf Systemsteuerung/Software/MSO Pro 2003 > Ändern
- Erste Eigenheit: Der MSO-Installer springt an! Das tut er sonst an dieser Stelle nicht. Und er macht das bei jedem Aufruf des O2003-Pro-Eintrags von neuem.
- Dann Auswahl "Features hinzufügen/entfernen" ... Erster Fehler: Alle Anwendungen sind angekreuzt, obwohl ich bisher etwa den Publisher noch nie installiert habe und er im Office11-Verzeichnis auch nicht vorhanden ist. Hier sollte sich ja normalerweise abbilden, was bereits installiert ist und was nicht.
- Dann "Erweiterte Anpassung" aktivieren und "Weiter" klicken... Und nun sind ALLE Features der einzelnen Komponenten mit dem Symbol für "Bei der ersten Anwendung installiert" versehen! Ich sehe also nicht, welche Komponenten bereits installiert sind oder auf welche Art. Das ist schon ziemlich übel, weil ich mir sowas nunmal nicht auswendig merke.

Hat jemand die gleichen Erscheinungen?

Ciao, Sascha

__________________

Microsoft Access MVP
O2k bis O2010, VB6, VS2008, Delphi7, ...
Bitte keine ungefragten E-Mails. Probleme werden hier gelöst.
Bitte beachten: Grundlegendes zum Access-Forum

Knowhow auf Access-im-Unternehmen | Das Access 2007 Praxisbuch für Entwickler | www.mossTOOLs.de
Sascha Trowitzsch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 18:36 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.